Sign in Join
Wiki copytemporary

Main menu/fi

Deutsch · English · Español · Français · Italiano · Magyar · Nederlands · Português · Shqip · Slovenčina · Suomi · Македонски · Русский · 中文(中国) · 中文(台灣) · 日本語

Päävalikko

Päävalikko sisältää seuraavat nimikkeet:

Tiedosto   Muokkaa   Etsi   Näytä   Lähdekoodi   Projekti   Suorita-valikko   Paketti   Työkalut   Ikkunat   Ohje

Kuten tavallista, vaihtoehdot voidaan valita joko asettamalla hiiren osoitin valikkokohdan ja klikkaamalla hiiren vasenta painiketta.

Tiedosto-valikko

Muokkaa-valikko

Etsi-valikko

niin se siirtyy tähän tiedostoon missä on tämä Include kutsu.

Näytä-valikko

Ohjaa näytön eri ikkunoita ja paneeleita ruudulla.

jotka näyttävät riippuvuudet. Yksitäistä tiedostoa tutkittaessa, riippuvuudet tulee esiin usein hyvin rekursiivisella tavalla.

Lähdekoodi-valikko

Projekti-valikko

Suorita-valikko

Avaa monisivuisen ikkunan, jonka avulla komentorivivalitsimia ja parametrejä välitetään ohjelman suoritettavaksi; mahdollistaa näytön valinnan missä ohjelma ajetaan (esim etäkäyttöinen X-pääte voidaan käyttää Linuxissa); joitakin järjestelmän ympäristömuuttujia voidaan ohittaa. Yksi tärkeä käyttö tässä alivalikossa on aktivoida pääteikkunaa jossa tavanomainen Pascal konsolin (päätteen) input / output näytetään. Jos kehitetään konsoli-tilassa toimivia Pascal ohjelmia (eli sellaisia jotka eivät käytä graafista käyttöliittymää ja sen lomakkeita, painikkeita ja laatikoita) sitten sinun pitäisi tarkistaa valintaruutu "Käytä käynnistävää ohjelmaa". Kun ensimmäisen kerran tehdä tämän ja yrittää "Käännä / Suorita" komentojensarjaa, saanet todennäköisesti "töykeän" viestin:

text
"xterm: Can't execvp /usr/share/lazarus//tools/runwait.sh: Permission denied".

Jos näin tapahtuu, niin täytyy muuttaa tiedoston käyttöoikeuksia sopivaksi (esimerkiksi käyttämällä chmod + x tiedostonimi tai Windowsin apuohjelmaa käyttöoikeuksien muuttamista); ehkä tämä täytyy tehdä root oikeuksilla. Tämän jälkeen joka kerta kun käynnistää ohjelman, konsoli aukeaa ja kaikki teksti I / O (readln, writeln ym) ilmestyy siihen. Kun ohjelma on päättynyt suorituksen, viesti "Press Enter" ilmestyy näyttöön. Niinpä mikä tahansa ohjelmalla luotu ulostulo pysyy näytöllä, kunnes olet ehtinyt lukea sen; kun painat Enter niin konsoli-ikkuna sulkeutuu. Katso erillinen opetusohjelmaPascal ohjelmointi päätetilassa.

Näillä kolmella viimeisellä vaihtoehdon avulla voidaan avata (ja ylläpitää) testausprojektia. Käytä Tiedosto -> Avaa avata .lpr tiedosto painamalla peru ja seuraava dialogi avaa tiedoston "normaalina" lähdekooditiedostona.

Paketti-valikko

Työkalut-valikko

Ikkunat-valikko

Sisältää luettelon tällä hetkellä avattujen tiedostojen ja käytettävissä olevia ikkunoita kuten lähekoodieditori, komponenttimuokkain ja projektin hallinta. Klikkaamalla yhden ikkunan nimeä niin tuo sen edustalle ja laittaa sen aktiiviseksi.

Ohje-valikko


From the Free Pascal wiki, page "Main menu/fi", as it stood on 2017-03-09 after a change by Djzepi, out of the wiki's dump of 2024-05-26. Copyright stays with the author who wrote it, according to the old wiki's Licensing page. If you have concerns about this material, message the admin.

Revision 3, last changed by WikiArchive .

Talk about this page

Nobody has opened a bench for this page yet. Sign in to open one.