Sign in Join
Wiki copytemporary

Main menu/it

Deutsch · English · Español · Français · Italiano · Magyar · Nederlands · Português · Shqip · Slovenčina · Suomi · Македонски · Русский · 中文(中国) · 中文(台灣) · 日本語

Il Menù Principale

Il menù principale contiene le seguenti voci: File Modifica Cerca Visualizza Progetto Esegui Package Strumenti Ambiente Finestre Aiuto

Come di consueto, le opzioni possono essere selezionate sia collocando il cursore del mouse sulla voce di menù e cliccando con il tasto sinistro del mouse, che digitando Alt-F sulla tastiera (purché il menù principale sia la finestra attiva: se non ce l'ha, premere ripetutamente il tasto TAB per passare da una finestra all'altra fino a che la finestra desiderata ha la barra del titolo attiva).

Le sotto-voci del menù File

Le sotto-voci del menu Edit

(begin ... end; try ... except; try ... finally; repeat ... until; { ... } etc).

Il sotto-menu cerca

'''

The View sub-menu

Controls the display of various windows and panels on the screen.

The Project sub-menu

The Run sub-menu

One very important use of this sub-menu is to activate a terminal window in which conventional Pascal console input/output is displayed. If you are developing a console-mode Pascal program (ie one that doesn't use the Graphical User Interface with its forms, buttons and boxes) then you should check the box for "Use launching application". The first time you do this and try the Compile/Run sequence, you will probably get a rude message to say

"xterm: Can't execvp /usr/share/lazarus//tools/runwait.sh: Permission denied".  

If this happens, you need to change the permissions on the appropriate file (for example using chmod +x filename, or using the Windows utility for changing permissions); you might have to do this as root. After this, each time you launch you program, a console box will appear and all your text i/o (readln, writeln etc) will appear in it.

After your program has finished execution, a message "Press enter" appears on the screen. Thus any output your program generated will remain on the screen until you have had a chance to read it; after you press 'enter' the console window closes.

Note: as for the current version, there is no prepared console command for Windows users. Until the Lazarus team adressess that, the following line should work (on WinXP -- someone please update for other Windowses)

C:\Windows\system32\cmd.exe /C ${TargetCmdLine}

See the separate tutorial on Console Mode Pascal programming.

These last three options enable you to open (and maintain) a test project. Use File -> Open to open an .lpr file, pressing cancel on the next dialog to open this file as "normal source" file.

The Package sub-menu

The Tools sub-menu

The Environment sub-menu

Most of these settings are auto generated and read only.

The Windows sub-menu

Contains a list of the currently opened files and the available windows such as Source Editor, Object Inspector and Project Inspector. Clicking on the name of one of the windows brings it to the foreground and gives it focus.

The Help sub-menu

At present this has three selections:

At present by default, if you place your Editor cursor over any keyword from the FreePascal Components Library FCL, the RunTime Library RTL or the Lazarus Components Library LCL, and then press <<F1>> you will be taken by your default browser to the appropriate definition on the website. Be aware that your browser may be located on another desktop on your machine (eg in Linux), and you may not see the information immediately; of course if you are not connected to the internet you cannot get this information. THIS SECTION STILL REPRESENTS WORK IN PROGRESS

Eventually there will be a full on-line Help service, with information about Pascal syntax, the use of the IDE, how to use, modify or create Components, and hints on how to perform certain tasks. This part of the Documentation section (the thing you are currently reading) represents the beginning of the process. We need contributions from anyone who feels able to provide them: the WiKi is very easy to edit.


From the Free Pascal wiki, page "Main menu/it", as it stood on 2021-12-08 after a change by Kupferstecher, out of the wiki's dump of 2024-05-26. Copyright stays with the author who wrote it, according to the old wiki's Licensing page. If you have concerns about this material, message the admin.

Revision 2, last changed by WikiArchive .

Talk about this page

Nobody has opened a bench for this page yet. Sign in to open one.