Sign in Join
Wiki copytemporary

Main menu/sk

Deutsch · English · Español · Français · Italiano · Magyar · Nederlands · Português · Shqip · Slovenčina · Suomi · Македонски · Русский · 中文(中国) · 中文(台灣) · 日本語

Základné menu (Main Menu)

Riadok základného menu obsahuje nasledujúce položky:

File Edit Search View Project Run Components Tools Environment Windows Help

Ako je zvykom, položky môžu bať vybraté umiestnením myši nad položku menu a kliknutím ľavým tlačítkom myši alebo stlačením Alt-F na klávesnici (základné okno musí mať fokus, ak ho nemá stláčajte opakovane TAB na prepínanie fokusu medzi oknami, kým nie je titulkový pruh uíkladného okna zvýraznený farbou).

Menu File

Menu Edit

Menu Search

'''

Menu View

Ovládanie zobrazenia rôznych okien a panelov na obrazovke.

http://lazarus-ccr.sourceforge.net/kbdata/ViewMenuSnapshot.png

Menu Project

Menu Run

Veľmi zaujímavou možnosťou tohoto sub-menu je aktivácia okna terminálu pre zobrazenie vstupu/výstupu konvenčnej konzoly Pascalu. Ak pracujete na konzolovom programe Pascalu, (tj. nepoužijete pre program GUI s formulármi, tlačítkami...), potom môžete zaškrtnúť políčko "Use launching application". Keď to nastavíte prvý krát a skúsite sekvenciu Compile/Run, asi dostanete divoké hlásenie hovoriace

text
"xterm: Can't execvp /usr/share/lazarus//tools/runwait.sh: Permission denied".

Ak toto nastane, potrebujete zmeniť prístupové práva príslušného súboru; možno to budete musieť urobiť ako root (administrator). Po tomto, sa pri každom spustení programu objaví konzolové okno, v ktorom sa budú obajovať všetky vaše textové vstupy/výstupy (readln, writeln ...).

Po skončení práce vášho programu sa objaví na obrazovke správa "Press enter". Takto celý výstup generovaný vašim programom ostane na obrazovke, aby ste mali šancu prečítať si ho a okno bude zatvorené až po stlačení 'enter'.

Poznámka: keďže v aktuálnej verzii nie je pripravený príkaz konzoly pre používateľov Windows. Zatiať Lazarus team odkazuje, že musí pracovať nasledujúci príkaz (vo WinXP)

text
C:\Windows\system32\cmd.exe /C ${TargetCmdLine}

Tieto posledné tri voľby umožňujú otvoriť (a spravovať) testovací projekt. Použite File -> Open pre otvorenie súboru .lpr a v nasledujúcom dialógu stlačte cancel pre otvorenie tohoto súboru ako "normálneho zdrojového" súboru.

Menu Components

Menu Tools

Menu Environment

Menu Windows

http://lazarus-ccr.sourceforge.net/kbdata/WindowsMenuSnapshot.png

Obsahuje zoznam aktuálne otvorených súborov a dostupných okien, ako Source Editor, Object Inspector, či Project Inspector. Kliknutím na názov jedného z okien je okno vyvolané do popredia a získava zameranie.

Menu Help

Časom tu bude úplný on-line Help, s informáciami o syntaxe Pascalu, o použití IDE, o používaní, úpravách a tvorbe komponentov a tipy ako urobiť niektoré úlohy. Táto časť sekcie Dokumentácia (to čo teraz čítate) predstavuje začiatok procesu. Potrebujeme spolupracovníkov, ktorí sú ochotní pomôcť: Editácia WiKi je veľmo jednoduchá.


From the Free Pascal wiki, page "Main menu/sk", as it stood on 2021-12-08 after a change by Kupferstecher, out of the wiki's dump of 2024-05-26. Copyright stays with the author who wrote it, according to the old wiki's Licensing page. If you have concerns about this material, message the admin.

Revision 3, last changed by WikiArchive .

Edited on wiki.freepascal.org by 1 person, 2021

From the official wiki's backup of 26 May 2024: who edited this page there, and when. Edits made there after that date were not recorded, and the earlier versions are not shown here; the main page says why.

WhenWhoWhat changed
KupferstecherContent from the Lazarus Tutorial/sk page (now linked to here)

Talk about this page

Nobody has opened a bench for this page yet. Sign in to open one.