Sign in Join
Wiki copytemporary

Main menu/nl

Deutsch · English · Español · Français · Italiano · Magyar · Nederlands · Português · Shqip · Slovenčina · Suomi · Македонски · Русский · 中文(中国) · 中文(台灣) · 日本語

Het Hoofdmenu

Het hoofdmenu bevat de volgende keuzes: File Edit Search View Project Run Components Tools Environment Windows Help

De keuzes kunnen op de bekende manieren geselecteerd worden, door een klik met de muis of door het gebruik van de Alt toets in combinatie met de onderstreepte latter. De F10 toets zorgt er ook voor dat het menu actief wordt.

Het File menu

Het Editmenu

Het Searchmenu

'''

Het View menu

Geeft je de controle over welk van de verschillende schermen op je desktop actief wordt.

Het Project menu

Het Run menu

Een belangrijk gebruik hiervan is het activeren van een terminal scherm waarin de consol invoer en uitvoer kan worden getoond. Als je een terminal programma (console-mode) ontwikkeld, dan moet je het vinkje zetten bij "Use launching application". Een eerste keer hun je een foutmelding krijgen als:

text
"xterm: Can't execvp /usr/share/lazarus//tools/runwait.sh: Permission denied".

Dit betekent dat je de rechten voor dit bestand even goed moet zetten (bijv. met chmod +x filename). Hierna zal er als het programma gestart wordt, een terminal scherm openen waarin alle invoer en uitvoer (readln, writeln) getoond zal worden.

Nadat het programma is afgesloten verschijnt in de schermpje een "Press enter" bericht, zodat je na afloop van het programma nog de tijd hebt om de in- en uitvoer na te lezen.

Zie ook de lessen voor Console Mode Pascal-programmeren.

Deze laatste drie opties maken het je dus mogelijk om een klein testprojectje te laden en dat uit te voeren. Open het de project file (.lpr) dan wel als "normal source" door op "Cancel" te klikken als Lazarus deze vraag toont.

Het Components-menu

Het Tools-menu

Het Environment-menu

http://lazarus-ccr.sourceforge.net/kbdata/EnvironmentMenuSnapshot.png

  1. Controleren of het pad van de fpc source directory nog goed staat in de environment opties.
  2. Re-scan FPC source directory.

The Windows sub-menu

Geeft een lijst van geopende schermen zoals de Source Editor, Object Inspector en Project Inspector. Het klikken op de naam van een van deze schermen brengt dit scherm naar de voorgrond.

Het Help menu

Op dit moment zijn er vier keuzes:

Het is de bedoeling dat er uiteindelijk een volledige Help zal zijn, met informatie over de Pascal syntax, het gebruik van de IDE etc etc. Het huidige document zal daar een onderdeel van zijn, dus: We need contributions from anyone who feels able to provide them: the WiKi is very easy to edit. oftewel: We kunnen de hulp van iedereen gebruiken die denkt te kunnen helpen: de WiKi kun je eenvoudig aanpassen!


From the Free Pascal wiki, page "Main menu/nl", as it stood on 2023-11-25 after a change by Bart, out of the wiki's dump of 2024-05-26. Copyright stays with the author who wrote it, according to the old wiki's Licensing page. If you have concerns about this material, message the admin.

Revision 3, last changed by WikiArchive .

Talk about this page

Nobody has opened a bench for this page yet. Sign in to open one.