Sign in Join
Wiki copytemporary

Main menu: history

RevisionWhenWhoWhat changed
4WikiArchiveEdited on wiki.freepascal.org 2024-12-29; the archived page does not name the editorWhat changed
3MartinFrom the Free Pascal wiki's dump of 2024-05-26What changed
2MartinFrom the Free Pascal wiki's dump of 2024-05-26What changed
1MartinFrom the Free Pascal wiki's dump of 2024-05-26What changed
Edited on wiki.freepascal.org by 6 people, 2017–2023

From the official wiki's backup of 26 May 2024: who edited this page there, and when. Edits made there after that date were not recorded, and the earlier versions are not shown here; the main page says why.

WhenWhoWhat changed
ArentCreated page
Arent
Arent
Arent
Arent
Arent
Djzepi
Arent
ArentView
ArentProject
ArentView
ArentView
ArentView: updated to actual contents 2.1.0
Arent
TrevRun: Clarify Build command (minor)
TrevHelp: Link Tools (minor)
TrevHelp: Add missing entry to Help menu
TrevHelp: Make menu chain readable (minor)
TrevRun: Corrected Cleanup and Build... menu item caption and description
TrevRun: Corrected the Compile item description
TrevTools: Link Options to its page and correct a typo
TrevCorrect heading levels (minor)
TrevHelp: Link Tools > Options > Help > Help Options parts to their IDE pages
TrevFix Menu Project link (was lowercase, but heading has initial cap) (minor)
TrevProject: Link New project to its IDE page
TrevFile: Link File > New... to its IDE page
TrevTools: Linked Configure external tools to its IDE page and clarified description
TrevSearch: Link Find to its IDE page
TrevSearch: Link Find in files to its IDE page
TrevSearch: Linked Find Identifier references to its IDE page
TrevCosmetic tweak to the fake main menu bar to better separate options (minor)
TrevHelp: Fixed some typos (minor)
TrevRun: Fix description of Run; add missing Run without debugging; add missing Step over to Cursor; remove Run to Cursor as no longer exists
TrevRun: Fix typo (minor)
TrevProject: Links Units + Forms to IDE window page
TrevRun: Link Run Parms to IDE window
TrevProject: Remove dated comment; nest compiler options under project options; link Project Options and Compiler Options to their IDE window pages
TrevProject: Linked Publish Project to its IDE window
TrevProject: Link Project Inspector to its IDE window
TrevFile: Add updated menu from Laz 2.0.10 (Windows); update entries top reflect current menu
TrevFile: Add markup (minor)
TrevEdit: Add Lazarus 2.0.10 edit menu; add missing menu options
TrevEdit: Add missing option descriptions
TrevEdit: https://wiki.freepascal.org/IDE_Window:_Find_in_files
TrevFile: Fix typo
TrevEdit: Add "Select Code Block" description: not implemented
TrevSearch: Clarified Find Code Block Start description
TrevProject: Correct description of View Project Source
TrevHelp: Fix typo (minor)
TrevHelp: Remove commented out text (minor)
TrevPackage: Replace outdated image with Lazarus 2.0.10 image; add missing menu items: Package Links + Online Package Manager
TrevTools: Replace outdated image with Lazarus 2.0.10 version; add missing menu items; update menu item names
TrevTools: Add missing description for Convert Encoding of Projects or Packages
FTurtleExcuded redirect, deleted underscores (it is bad for search)
TrevSearch: Replace outdated search menu with Lazarus 2.0.10 version
TrevSearch: Update menu entries to match Lazarus 2.0.10; add missing entries; remove nonexistent entries
TrevFile: Add space separations to match menu (minor)
TrevEdit: Add space separations to match menu item grouping (minor)
TrevSource: Add space separations to match menu item grouping (minor)
TrevSource: Add space separations to match menu item grouping (minor)
TrevProject: Replace outdated Project Menu with Lazarus 2.0.10 version
TrevRun: Replace outdated run menu image with Lazarus 2.0.10 version; add space separations to match menu item grouping
TrevRun: Remove outdated info (minor)
TrevRun: Fix above and below :- (minor)
TrevView: Remove dead link (minor)
TrevView: Remove non-existent page links; fixed emboldening; add space separations to match menu grouping; replace outdated image; add missing menu items
TrevView: Fix two typos (minor)
TrevView: Add page link for History menu item
TrevView: Add page link for Debug Output menu item
TrevView: Fix typo (minor)
TrevView: Fix description of Debug History (minor)
TrevView: Add description for FPDoc Editor menu item
TrevSearch: Fix typo (minor)
TrevView: Add page link for BreakPoints menu item
TrevView: Add page links and description for Call Stack menu item
TrevView: Add page link for the Registers menu item
TrevView: Add page link and description for Assembler menu item
TrevView: Add page link and description for Threads menu item; fix typo
TrevView: Fix typo (minor)
TrevView: Add page link and description for the Watches menu item
TrevView: Add page link and description for Local Variables menu item
TrevView: Add page link and description for the Event Log menu item
TrevView: Fix typo (minor)
TrevView: Add description for Anchor Editor menu item
TrevView: Fix typos
TrevSource: Add page link to Unit Information menu item
TrevPackage: Add page link for the Online Package Manager menu item
TrevPackage: Add page link for Install/Uninstall Packages menu item
TrevPackage: Add page link for the Package Graph menu option
TrevSearch: Add page link for Replace menu item
TrevView: Add description for Restriction Browser menu item
TrevView: Shorten description of Code Explorer; relocate content to the linked Code Explorer page
TrevTools: Add menu spacing; add page link for Destops menu item; replace HTML markup with Wiki markup
TrevView: Added descriptions for "IDE Internals" sub-menu options
TrevWindow: Add page links (minor)
TrevView: Add description for ToDo option
TrevTools: Updated for Lazarus 2.2 and macOS; bypass page redirect (minor)
TrevAdd macOS menu keyboard shortcut (minor)
TrevHelp: Updated for macOS
TrevHelp: Add Lazarus version for macOS change
TrevPackage: Match separator spacing (minor)
ThierryboRun: Add Linux command line parameter if the console does not appear.
MartinView

Back to the page