On mandrake 7.1 ?! I don't think so, this is the latest version, I think. I am using…
Mandrake 7.1 is somewhat old. Latest version is Mandrake 8.0, on which it works.
And yes, minor version change matters here. The version 4 RPMs are supported by rpm-4.x shipped with RH 7.0 and higher or for older Red Hats (like 6.2) you have to upgrade to rpm 3.0.5 or higher to be able to use these packages.
The update to rpm 3.0.5 is officialy recommended by Red Hat for their older distros if you need to install these new format RPMs.
Michal
