TMainMenu/ja: what changed
Revision 1 to 2. Removed lines have a minus sign; added lines have a plus sign.
| Old | New | Line | |
|---|---|---|---|
| 1 | 1 | \>\> [[LCL Components]] \>\> TMainMenu | |
| 2 | 2 | ||
| 3 | 3 | **TMainMenu** はフォームでメインメニューを提供する[[Component Palette/ja|コンポーネントパレットの]][[Standard tab/ja|Standardタブからの]]見ることのできないコンポーネントである。 | |
| 4 | 4 | ||
| 5 | 5 | ## 概要 | |
| 6 | 6 | ||
| 7 | 7 | フォームを設計するときに様々なメニューアイテムによって選ばれる、ほとんどのウインドウの先頭に現れるメインメニューである。 | |
| 8 | 8 | ||
| 9 | 9 | メニューエディタを見るにはフォームのメインメニューアイコンを右クリックすること。 | |
| 10 | 10 | ||
| 11 | 11 | ## 約束事 | |
| 12 | 12 | ||
| 13 | 13 | *mnu*、*menu*で始まる、あるいはmenuのそのものをメニュー(menu)と名付けるのは一般的な慣習である。サブメニューがそれに含まれるメニューのプリフィクスとともに続く。例えば、「編集(Edit)」にある「切り取り(Cut)」サブメニューはたいてい*mnuEditCut*もしくは、*menuEditCut*と名付けられる。これは今から6か月後に変更する必要が生じたときに、それらを中に入れる仕方の記憶を助け、覚えやすいが、*慣習*であり、強制ではないことに注意すること。しかし、このようにすることは後々変更したり、しばらくコードを見ていないときに、あるいは、書かれたプログラムをメンテナンスしなければならない、誰かほかの人間にとって、おそらくそれが何をしているかを理解する手助けになるだろう。 | |
| 14 | 14 | ||
| 15 | 15 | 始めてみよう | |
| 16 | 16 | ||
| 17 | 17 | ## メニューを作成する | |
| 18 | 18 | ||
| 19 | 19 | 1. コンポーネントバーからTMainMenuを選び、フォーム上でそれをクリックするが、マウスボタンは離さずに押したまま、箱を描いてマウスボタンを離す。そのコンポーネントがフォームに現れるだろう。これはドロップダウンメニューとデフォルトのコンポーネント名が*MainMenu1*となった四角形が現れるだろう。 | |
| 20 | 20 | 2. もし**MainMenu1**と言う名前が気に食わなければ、オブジェクトインスペクタウィンドウに移動して、よりよいと考えるものにNameプロパティを変更する。ここでは*XMenu*に変更する。Nameプロパティの左の箱に**XMenu**とタイプして、エンターを押す。コンポーネントの名前が変更される。 | |
| 21 | 21 | 3. XMenuを右クリックすると、ポップアップメニューが現れる。ここで、必要なのは最初のセクション、**Menu Editor**である。それをクリックする。 | |
| 22 | 22 | 4. Menu Editorウィンドウが「New Item1」のキャプションを持つ、すでに作られたメニューアイテムが開く。いつも見ている「ファイル 編集 表示 ヘルプ」のトップレベルメニューとなり、おそらくこれを変更したいだろう。そのためにはクリックし、オブジェクトインスペクタに移動する。 | |
| 23 | 23 | 5. オブジェクトインスペクタでNameプロパティをMenuItem1からよりふさわしいものに変更する。これをFileメニューと呼ぶことにする。そこで**mnuFile**とタイピングし、エンターを押すことでこれを変更する。 | |
| 24 | - | ||
| 25 | - | ||
| 26 | - | ||
| 24 | + | 6. New Item1よりも良い名前が欲しいので、Captionプロパティに移動し、**&File**とタイプし、エンターを押す。名前の前のアンパサンド**&**はAltキーと下線が引かれたキーを押すことにより、メニューを開くことのできる*アクセラレータ*である。このメニューに対するキャプションを**File**へと変更する。この時点で、1つのトップレベルメニュを加えたことになる。 | |
| 25 | + | 7. Menu Editorウインドウに戻る。Fileをクリックし、次に右クリックする。ポップアップメニューが現れる。*Insert New Item After*をクリックし、*New Item2*という名前の新しいメニューが現れる。2つのアイテムですでに説明したように、オブジェクトインスペクタでその名前を**mnuHelp**、この名前を**mnuHelp**、キャプションを**&Help**に変更する。 | |
| 26 | + | 8. これをFileの下のメニューアイテムにする。右クリックし、**Create Submenu**をクリックする。ファイルメニューは矢印を持ち、# *New Item2*という名前のサブメニューが現れる。 | |
| 27 | 27 | ||
| 28 | 28 | これをそれが行う何かに関連したものに変更する、ここでは「開く」ということにする。オブジェクトインスペクタに移動し、Nameプロパティを**mnuFileOpen**、キャプションを**&Open**に変更する。 | |
| 29 | 29 | ||
| 30 | - | ||
| 30 | + | 1. トップレベルメニュー**File**と**Help**の間にまたトップレベルメニューが必要である。**File**を右クリックし、**Insert New Item (after)**するか、**Help**を右クリックし、**Insert New Item (before)**をクリックすることができる。 | |
| 31 | 31 | 2. このアイテムのプロパティをオブジェクトインスペクタで**mnuEdit**へ変更する。 | |
| 32 | 32 | 3. 必要なら、それぞれのメニューとサブメニューに応じて上記を繰り返す。 | |
| 33 | 33 | ||
| 34 | 34 | これで、すべてが実行時に表示され、ユーザーはメニューをクリックすることができる。これは実際には何もしない。メニューアイテムに何かをさせるときは、クリックされると反応することになっている、それぞれのメニューとサブメニューに[[Event order|eventsを]]加えなければならない。通常はトップレベルメニューは反応しないが、サブメニューは反応する。メニューの反応のさせ方に2つの選択肢があり、メニューの中にイベントを挿入するか、あるいは[[TActionList|TActionListコンポーネントを]]用いることもできる。TActionListを用いる主な理由はもし、ツールバーにアイコンを加えるつもりがあるならば、まず、「ファイル」そして、「開く」、「保存」、「名前をつけて保存」、「閉じる」などのメニューをサブメニューとして持ち、同様にツールバーに「新規」、「開く」、「保存」、「名前をつけて保存」ボタンがあるツールバーを持つことになる。「新規」、「開く」機能を扱う2つのルーチンを書くより、メニューとツールバー双方にTActionListを持つ。TActionListを使う仕方はほかに譲る。当面はオブジェクトエクスプローラでイベントを用いての、メニュークリックを扱う仕方を説明する。 | |
| 35 | 35 | ||
| 36 | 36 | ## 実際に何かをするメニューを作成する | |
| 37 | 37 | ||
| 38 | - | ||
| 38 | + | 1. Menu Editorウインドウに戻り、**File**以下にあるサブメニュー**Open**をクリックする。オブジェクトインスペクタウインドウに行き、**Events**タブをクリックする。変えたいイベント何もないはOnClickのみである。あると好ましい、存在するイベントハンドラを持っているならば、用いることができるが、それはないため、Lazarusにそれを作らせることができる。3つのボタンの右に3つのドット(...)がある。これをクリックすると、新しいプロシージャがコードの中に生成され、コードウインドウにヴューが切り替わる。これは以下のように見えるだろう。 | |
| 39 | 39 | ||
| 40 | 40 | ``` pascal | |
| 41 | 41 | procedure TfrmMain.mnuFileOpenClick(Sender: TObject); | |
| 42 | 42 | begin | |
| 43 | 43 | end; | |
| 44 | 44 | ``` | |
| 45 | 45 | ||
| 46 | - | ||
| 46 | + | 1. **begin**と**end**ステートメントの間にメニューのオープンアクションを書くだろう。これはフォーム上のDaialogs tabから*TOpenDialog*コントロールを配置するかもしれない。同様のことが **Save**、**Save as**サブメニューを持つと適用される。 | |
| 47 | 47 | 2. どのようにしてメニューとサブメニューを加えるかについて上で言及した点を繰り返すことになり、それぞれはユーザーによってクリックされる1つ1つについて必要ならばイベントハンドラを作るだろう。 | |
| 48 | 48 | ||
| 49 | 49 | ## チェックボックスメニュー | |
| 50 | 50 | ||
| 51 | 51 | さて、チェックボックスが欲しくなったかもしれない、ユーザーがクリックするとそれはチェックマークがついたり、消えたりする。これを行う方法を議論する。 | |
| 52 | 52 | ||
| 53 | - | ||
| 54 | - | ||
| 53 | + | 1. Menu Editorウインドウに移り、**Edit**をクリックする。 | |
| 54 | + | 2. Editの下にメニューアイテムを作ろう。右クリックし、 **Create Submenu**をクリックし、オブジェクトインスペクタウインドウで、もしすでに選択されていなければ、プロパティタブをクリックする。このサブメニューを**mnuEditPreserve**と名づけキャプションを**P&reserve case**とする(コピーアンドペーストが通常ALT+PとALT+Cを使うので、このサブメニューにはALT+Rを使う。これが「r」の前にアンパサンドを置いた理由である)。 | |
| 55 | 55 | ||
| 56 | 56 | 1. デフォルト値、*チェック(checked)*をFalseにする. もしこのメニューのデフォルト状態がチェックなら、値をダブルクリックしてFalseからTrueに変えること。 | |
| 57 | 57 | 2. **Events**タブを選択して、**Click**プロパティを選び、...ボタンをクリックする。 | |
| 58 | 58 | 3. Lazarus はコードウインドウに切り替わり、このサブメニューに対してClickイベントを生成する。 | |
| 59 | 59 | 4. **begin**と**end**のあいだでには、以下のような一行のみを記入すればよい: | |
| 60 | 60 | 5. mnuEditPreserve.checked := not mnuEditPreserve.checked ; | |
| 61 | 61 | 6. これが値をチェックからアンチェックに切り替える。コードの中でこのチェックされたメニューを使うことができるようにするには**`mnuEditPreserve.checked`**を参照すればよい (もしくはメニューの名前が何であれ、プロパティが*checked*のもの)。それはほかのどの[[Boolean]] 値に関しても同様である。 | |
| 62 | 62 | ||
| 63 | 63 | ## セパレータ | |
| 64 | 64 | ||
| 65 | - | ||
| 65 | + | 時には線で区切られている項目を持つメニューが必要な時がある。例えば、**Edit**メニューは**Cut**、**Copy**、**Paste**サブメニューを持ち、次のサブメニューの前にセパレータラインを持つかもしれない。セパレータラインを作るには、もう1つのサブメニューを作り、キャプションが1つのダッシュ(-)からなるようにすればよい。 | |
| 66 | 66 | ||
| 67 | 67 | ## ショートカット | |
| 68 | 68 | ||
| 69 | 69 | もし望むのであれば、メニューに対して特定のキーの組み合わせを割り当てることができる、以下の手順である: | |
| 70 | 70 | ||
| 71 | 71 | - メニューエディタでキーボードショートカットを割り当てるメニューを選択する。 | |
| 72 | 72 | - オブジェクトインスペクタでプロパティ、*ShortCut*に移動し\[...\]ボタンをクリックする。 | |
| 73 | 73 | - メニューに望むショートカットを選択できるウインドウが現れる。 | |
| 74 | 74 | - メニューのランタイムイベントハンドラはこのショートカットをこのメニューをクリックしたしたかのように呼び出す。 | |
| 75 | 75 | ||
| 76 | 76 | ## メニューの前の画像 | |
| 77 | 77 | ||
| 78 | 78 | もしメニューを視覚的に際立たせたい、あるいは可能なツールバーに対するメニュー項目の光学マッピングを確立したいのなら、メニューの前に画像を表示させることができる。以下の手順が必要である: | |
| 79 | 79 | ||
| 80 | 80 | - [[TForm|フォームに]][[TImageList|イメージリストを]]追加する。これはコンポーネントパレット*Common Controls*で見つけられる。TImageListを選択し、Form上にクリックして配置する。*ImageList1*という名のこれでイメージリストがフォーム上に生成される。これらのイメージリストはメニューの前に表示されるすべてのシンボルや画像を含んでいる。 | |
| 81 | 81 | - *ImageList1*を右クリックし、**ImageList Editor**を開く。 | |
| 82 | 82 | - メニューに必要なすべての画像をImageListに次々に加える。単にボタン*Add*をクリックし、相応しい画像をいつも通り加える。 | |
| 83 | 83 | - ImageListに必要とされるすべての画像をすべての画像を加えたら、\[OK\]ボタンで選択を確認し、ImageList Editorを閉じる。 | |
| 84 | 84 | - そして、MainMenuを選択しなければならず、オブジェクトインスペクタでImageListにプロパティ*Images*を設定する。単に隣のコンボボックスでImageList *ImageList1*を選択する。 | |
| 85 | 85 | ||
| 86 | 86 | - そして、メニューエディタでメニューを再び開き、画像を得たいメニューを選択する。 | |
| 87 | 87 | - メニューからオブジェクトインスペクタの*ImageIndex*プロパティへ移動し隣のコンボボックスに表示されている画像を選択する。 | |
| 88 | 88 | - Menu Editorで次のメニューを選択し、それに対応する画像を選択する。など。 | |
| 89 | 89 | ||
| 90 | 90 | ## 問題: 左側にサブメニューがドロップダウンする(Windows Vista、7、10) | |
| 91 | 91 | ||
| 92 | 92 | もし、プルダウンメニューがメインメニューアイテムの右に並び、サブメニューが左に開いたら、それはWindowsが**Tablet PC Settings**で**Right-handed(右利き)**に設定されている。これはタブレットを用い、画面で記入/押す、でメニューが直接的に表示されるときにおこる。もし右利きなら、メニューを左側に表示したいかもしれない。そうするとメニューは手の下側に現れない。通常のPC操作ではこれをデフォルトで左利きに設定されている。 以下を行うことでこれを確かめることができる: | |
| 93 | 93 | ||
| 94 | 94 | - Window-key + Rを押す。 | |
| 95 | 95 | - **shell:::{80F3F1D5-FECA-45F3-BC32-752C152E456E}**を入力しエンターを押す。 | |
| 96 | 96 | - **Other(その他)**タブに移動する。 | |
| 97 | 97 | - デフォルトが**Left-handed(左利き)**に設定されるべきで、メニューが右に現れるようになっており、さもなくば左に現れる。 | |
| 98 | 98 | - 注意: 設定にかかわらずサブメニューの矢印はそれでもメニューの右側に現れるだろう。 | |
| 99 | 99 | ||
| 100 | 100 | ## ランタイムを作成する | |
| 101 | 101 | ||
| 102 | 102 | ランタイムにTMainMenuを作るためには、フォームの所有者をTMainMenuに指定するべきである。 | |
| 103 | 103 | ||
| 104 | 104 | ``` pascal | |
| 105 | 105 | mnuMainMain = TMainMenu.Create(Form1); | |
| 106 | 106 | ``` | |
| 107 | 107 | ||
| 108 | 108 | (注意、親を指定することは不要であり、アプリケーションを所有者として指定することは望んだ効果が得られない) | |
| 109 | 109 | ||
| 110 | 110 | ## 以下も参照のこと | |
| 111 | 111 | ||
| 112 | 112 | - [[doc:lcl/menus/tmainmenu.html|TMainMenu doc]] | |
| 113 | 113 | - [[TPopupMenu]] | |
| 114 | 114 | - [[TActionList]] | |
| 115 | 115 | ||
| 116 | 116 | --- | |
| 117 | 117 | *From the Free Pascal wiki, page "TMainMenu/ja", as it stood on 2024-03-20 after a change by Ariben, out of the wiki's dump of 2024-05-26. Copyright stays with the author who wrote it, according to the old wiki's [[Licensing]] page. If you have concerns about this material, [message the admin](/wiki-contact).* |
