Sign in Join
Wiki copytemporary

Main menu/pt: what changed

Revision 1 to 2. Removed lines have a minus sign; added lines have a plus sign.

OldNewLine
11**O Menu Principal**
22
3-O menu principal contem as seguintes entradas em inglês: <u>F</u>ile <u>E</u>dit <u>S</u>earch <u>V</u>iew <u>P</u>roject <u>R</u>un <u>C</u>omponents <u>T</u>ools E<u>n</u>vironment <u>W</u>indows <u>H</u>elp
3+O menu principal contem as seguintes entradas em inglês: File Edit Search View Project Run Components Tools Environment Windows Help
44
55Como de costume, as opções podem ser selecionadas colocando o cursor do mouse(ponteiro) sobre a opção do menu e clicando(estalando) o botão esquerdo do mouse(ponteiro), ou digitando o Alt-F no teclado (fornecido a janela do menu principal tem foco: se não tiver, aperte Tab repetidamente para dar um ciclo no foco através das várias janelas até que a janela desejada tenha sua barra do título destacada na cor).
66
77#### O sub-menu Arquivo(File)
88
9-<div class="floatright">
10-
119<http://lazarus-ccr.sourceforge.net/kbdata/FileMenuSnapshot.png>
1210
13-</div>
14-
1511- **Nova Unidade**: Cria um arquivo para nova unidade (Pascal Source).
1612- **New Form**: Cria um novo formulário: uma janela visual da tela e seu arquivo fonte Pascal associado.
1713- **Novo ...**: Abre uma caixa ([screenshot](http://lazarus-ccr.sourceforge.net/kbdata/menu-new.jpg)) com uma variedade de novos tipos de documentos para criar.
1814- **Abrir**: Abre uma caixa de diálogo que habilita você a navegar pelos arquivos e escolher um existente arquivo para abrir.
1915- **Revert**: Remove as mudanças durante a edição e restaura o arquivo para seu estado original.
2016- **Salvar**: Salva o arquivo corrente(em uso), utilizando seu nome original do arquivo. Se este não tiver um nome, o sistema irá perguntar pelo nome que você deseja salvar(como no Save As).
2117- **Save As**: Permite que você escolha um diretório e um nome de arquivo para salvar o arquivo atual.
2218- **Fechar**: Fecha o arquivo atual, perguntando se salva todas as mudanças do editor..
2319- **Close all editor files**: Fecha todos os arquivos abertos no editor. E oferece para salvar mudanças.
2420- **Clean directory**: Disponibiliza um diálogo com uma série de filtros editáveis para remoção de arquivos do corrente diretório. Muito utilizado para remoção de arquivos .bak e restir que formavam os projetos Delphi.
2521- **Sair**: Sai do ambiente Lazarus, depois de perguntar se salva todos os arquivos editados.
2622
27-<div style="clear:both;">
28-
29-</div>
30-
3123#### O sub-menu Editar(Edit)
3224
33-<div class="floatright">
34-
3525<http://lazarus-ccr.sourceforge.net/kbdata/EditMenuSnapshot.png>
3626
37-</div>
38-
3927- **Undo**: Desfaz a última ação de edição.
4028- **Redo**: Refaz a última ação de edição que foi revertida pelo Undo.
4129- **Cut**: Remove o texto ou item selecionado e o coloca na área de transferência.
4230- **Copy**: Faz uma cópia do texto selecionado, deixando o original no lugar, e coloca uma cópia na área de transferência.
4331- **Paste**: Coloca o conteúdo da área de transferência na posição do cursor. Se texto tem sido selecionado na posição do cursor, o conteúdo da área de transferência irá substituir o texto selecionado.
4432- **Indent selection**: indenta(adiciona um espaço especificado) antes do texto selecionado.
4533- **Unindent selection**: desindenta(remove o espaço especificado) antes do texto selecionado.
4634- **Enclose selection**: disponibiliza um menu flutuante com opções para incluir o texto selecionado dentro de uma das opções(begin ... end; try ... except; try ... finally; repeat ... until; { ... } etc).
4735- **Uppercase selection**: passa todo o texto selecionado para caixa alta, letras maiúsculas.
4836- **Lowercase selection**: passa todo o texto selecionado para caixa baixa, letras minúsculas.
4937- **Tabs to spaces in selection**: Converte as tabulações(TAB) no texto selecionado em número de espaços especificados no Environment -\> Editor options -\> General -\> Tab widths. O número de espaços não tem quantidade fixa, mas é o número necessário para preencher a largura restante da tabulação.
5038- **Break lines in selection**: Se alguma linha no texto selecionado for maior que 80 caracteres ou que o número especificado em Environment -\> Editor options -\> Display -\> Right Margin, então a linha é quebrada no limite de palavras e continua na próxima linha.
5139- **Comment selection**: Torna o texto selecionado um comentário inserindo antes de cada linha os caracteres: // .
5240- **Uncomment selection**: Remove as marcas de comentários.
5341- **Sort selection**: Ordena linhas (ou palavras ou paragráfos) alfabeticamente; podendo ser : ascendente ou descendente; e sensitívo a caixa ou não. No meio do código fonte do programa, é claro, não faz sentido, mas se você tem uma lista em que você precisa ordená-la você utilizará esta ferramenta.
5442- **Select**: Seleciona blocos do texto. As opções incluem selecionar tudo, para apoiar, um parágrafo ou uma linha, etc.
5543- **Insert from character map**: Insere de símbolos não existentes no teclado como caracteres acentuados, obtém de janela com o mapa de caracteres.
5644- **Insert Text**:abre um menu à parte para inserir textos padrões: palavras chaves do CVS (Author, Date, Header etc) ou notícia do GPL, nome do usuário ou data e hora atual.
5745- **Complete code**: Muito utilizado pelo desenvolvedor permite completar o código de um método, procedimento ou função, declarado na interface. Ao chamar esta rotina ele é adicionado na implementação(implementation) com o cursor dentro deste para você programar este.
5846- **Extract procedure**: Usa o texto selecionado(a statement or series of statements) para gerar um novo procedimento(procedure).
5947
60-<div style="clear:both;">
61-
62-</div>
63-
6448#### O sub-menu Localizar(Search)
6549
66-<div class="floatright">
67-
6850<http://lazarus-ccr.sourceforge.net/kbdata/SearchMenuSnapshot.png>
6951
70-</div>
71-
7252- **Find**: similar a facilidade encontrada na maioria dos editores de texto: uma caixa de diálogo aparece disponibilizando a entrada de um texto para procurar, com opções como: case sensitive(sensível a caixa: maiúscula \<\> minúscula), palavras inteiras, origem, escopo e direção da procura.
7353- **Find Next, Find previous**: procurar novamente pelo anterior texto entrado, na especificada direção.
7454- **Find in files**: procura pelo texto nos arquivos: diálogo com as opções: all open files(todos os arquivos abertos), all files in project (todos os arquivos no projeto) ou all directories(todos diretórios); mascara disponível para selecionar tipos de arquivo.
7555- **Replace**: parecido com "Find", exibe um diálogo com lugares para entrar com o texto para procurar e substituir, e opções para sensível à caixa(case sensitivity), direção(direction) etc.
7656- **Incremental find**: Procura pelo texto enquanto você está colocando os caracteres de procura. Exemplo: depois de você escolher "Incremental Find" se você pressionar "l" o primeiro "l" irá ser marcado. Se em seguida você apertar "a", o editor irá procurar o próximo "la" e marcá-lo. E assim por diante.
7757
7858- **Goto line**: Move o cursor de edição para uma linha específica no arquivo.
7959- **Jump back**: Move de volta no arquivo para a próxima marcação(precisa ter usado Add jump point no histórico). Irá mover para marcações em outros arquivos no editor.
8060- **Jump forward**: Move para próxima marcação.
8161- **Add jump point to history**: Adiciona marcações ou pontos de pulo para o arquivo.
8262- **View Jump-History**: Visualiza a lista de marcações no arquivo: Não implementada ainda.
8363- **Find other end of code block**: Se posicionado em um início de bloco, encontra o correspondente fim e vice-versa.
8464- **Find code block start**: Move para o início do procedimento ou função em que o cursor se encontra.
8565
8666- **Find Declaration at cursor**: Encontra o lugar em que o identificador selecionado é declarado. Pode ser o mesmo arquivo ou outro aberto no editor; se o arquivo não está aberto, ele será aberto (então se um procedimento ou função está declarado, por exemplo, no arquivo classesh.inc , este irá ser aberto no editor).
8767- **Open filename at cursor**: Abre o arquivo cujo o nome é selecionado no cursor. Útil para olhar arquivos incluídos ou que contêm outras unidades usadas no projeto.Opens the file whose name is selected at the cursor.
8868- **Goto include directive**: Se o cursor for posicionado em um arquivo que esteja incluído em um outro arquivo, vai ao lugar no outro arquivo que chamou o arquivo incluído.
8969
9070'''
9171
92-<div style="clear:both;">
93-
94-</div>
95-
9672#### O sub-menu Exibir (View)
9773
98-<div class="floatright">
99-
10074<http://lazarus-ccr.sourceforge.net/kbdata/ViewMenuSnapshot.png>
10175
102-</div>
103-
10476Controla as várias janelas e painéis exibidas da ferramenta(Lazarus) na tela.
10577
10678- **Object Inspector**: Esta janela usualmente ocupa o lado esquerdo do ambiente, e exibe as características, os atributos publicados(que se encontram no "published" da classe) do formulário(Form), módulo ou componente selecionado em um dos containers anteriores que está no ambiente.
10779- **Source Editor**: é a janela encarregada de editar o código fonte do programa, geralmente são arquivos de extensão: pas, pp e inc.
10880- **Code Explorer**: abre uma janela com as divisões do código fonte para facilitar o desenvolvimento.
10981- **Units**: abre uma janela que exibe todas as unidades(bibliotecas) utilizadas pelo projeto.
11082- **Forms**: abre uma janela que lista todas as janelas criadas e utilizadas no projeto.
11183- **View Unit Dependencies**: abre uma janela que exibe em árvore as unidades que o projeto depende.
11284- **Toogle form/unit view**: alterna entre o formulário e a unidade(biblioteca) do formulário.
11385- **Messages**: exibe a janela de mensagens de compilação, exibindo progresso da compilação ou listando os erros econtrados...
11486- **Search Results**: Uma janela que exibe os resultado de procura nos arquivos.
11587- **Debug windows**: Abre um menu com várias opções para operar e compilar o debugador.
11688
117-<div style="clear:both;">
118-
119-</div>
120-
12189#### O sub-menu Projeto(Project)
12290
123-<div class="floatright">
124-
12591<http://lazarus-ccr.sourceforge.net/kbdata/ProjectMenuSnapshot.png>
12692
127-</div>
128-
12993- **New Project**: Cria um novo projeto. Uma janela de diálogo aparece oferecendo a escolha de tipos de projeto para criar.
13094- **New Project from file**: Um diálogo de navegação aparece, aguardando a seleção de um arquivo para criar um novo projeto.
13195- **Open Project**: Abre um projeto existente que já tenha sido criado e salvo. Um diálogo de navegação aparece com uma lista de arquivos de informações de projetos lazarus(.lpi) para escolher.
13296- **Open Recent Project**: Exibe uma lista de projetos recentes que você tenha trabalhado recentemente para você selecionar.
13397- **Save Project**: Salva o projeto.
13498- **Save Project As**: Salva o projeto como, ou seja com um nome determinado por você.
135-
136-<div style="clear:both;">
137-
138-</div>
13999
140100---
141101*From the Free Pascal wiki, page "Main menu/pt", as it stood on 2021-12-08 after a change by Kupferstecher, out of the wiki's dump of 2024-05-26. Copyright stays with the author who wrote it, according to the old wiki's [[Licensing]] page. If you have concerns about this material, [message the admin](/wiki-contact).*

Back to history