Sign in Join
Wiki copytemporary

FPDoc Editor/ru: what changed

Revision 2 to 3. Removed lines have a minus sign; added lines have a plus sign.

OldNewLine
1-## Contents
2-
3- * 1 Вступление
4- * 2 Использование редактора FPDoc
5- * 3 FPDoc для поставляемых исходников LCL и самого Lazarus
6- * 4 Редактирование FPDoc для поставляемых исходников FPC, RTL and FCL
7- * 5 Планы на будущее
8- * 5.1 Уже сделано
9-
101## Вступление
112
12-FPDoc это встроенное в Lazarus средство для формирования документации к модулям Free Pascal. Подробное описание FPDoc есть на английском языке: [Free Pascal documentation tool manual](<http://www.freepascal.org/docs-html/fpdoc/fpdoc.html>).
3+FPDoc это встроенное в Lazarus средство для формирования документации к модулям Free Pascal. Подробное описание FPDoc есть на английском языке: [Free Pascal documentation tool manual](http://www.freepascal.org/docs-html/fpdoc/fpdoc.html).
134
14-[![FPDocEditorDescription.png](/wiki-images/6/6c/FPDocEditorDescription.png)](</File:FPDocEditorDescription.png>)
5+![](/wiki-images/6/6c/FPDocEditorDescription.png)
156
16-Lazarus включает средство просмотра FPDoc-справки во всплывающих подсказках к именам в исходном коде и два редактора FPDoc, которые могут использоваться для создания и поддержки документации к исходникам. Более простой редактор интегрирован в Lazarus IDE так и называется, **FPDoc Editor** (Редактор FPDoc), и именно он описан на этой странице. Для его работы достаточнов настройках Lazarus в разделе FPDoc добавить пути к папкам с документацией.
7+Lazarus включает средство просмотра FPDoc-справки во всплывающих подсказках к именам в исходном коде и два редактора FPDoc, которые могут использоваться для создания и поддержки документации к исходникам. Более простой редактор интегрирован в Lazarus IDE так и называется, **FPDoc Editor** (Редактор FPDoc), и именно он описан на этой странице. Для его работы достаточнов настройках Lazarus в разделе FPDoc добавить пути к папкам с документацией.
178
18-Существует также более мощный редактор, который называется [[Lazarus Documentation Editor|LazDE]]. **LazDE** \- старший брат **FPDoc Editor** , и полностью называется Lazarus Documentation Editor. Это самостоятельное приложение, оно не интегрировано в Lazarus IDE. Поставляется в исходниках, проект расположен в папке ($LazDir)/doceditor/lazde.lpi. Скомпилируйте проект lazde однажды (используя Lazarus), и затем запускайте LazDE независимо. Можно добавить его в меню Tools (Сервис) как "внешнее средство".
9+Существует также более мощный редактор, который называется [[Lazarus Documentation Editor|LazDE]]. **LazDE** - старший брат **FPDoc Editor**, и полностью называется Lazarus Documentation Editor. Это самостоятельное приложение, оно не интегрировано в Lazarus IDE. Поставляется в исходниках, проект расположен в папке (\$LazDir)/doceditor/lazde.lpi. Скомпилируйте проект lazde однажды (используя Lazarus), и затем запускайте LazDE независимо. Можно добавить его в меню Tools (Сервис) как "внешнее средство".
1910
2011## Использование редактора FPDoc
2112
22-Чтоб воспользоваться FPDoc Editor достаточно:
13+Чтоб воспользоваться FPDoc Editor достаточно:
2314
24-1\. Открыть пункт FPDoc Editor (Редактор FPDoc) в меню View (Вид).
15+1\. Открыть пункт FPDoc Editor (Редактор FPDoc) в меню View (Вид).
2516
26-2\. В редакторе исходного кода Lazarus поставить курсор на нужный элемент кода. Вы заметите, что заголовок окна редактора FPDoc изменился, и показывает имя этого элемента вместе с именем файла документации. В редакторе FPDoc Вы можете перейти на подходящую вкладку чтобы редактировать соответствующий тег документации. И естественно, Вы можете использовать редактор FPDoc и для просмотра имеющейся документации, не начиная менять её.
17+2\. В редакторе исходного кода Lazarus поставить курсор на нужный элемент кода. Вы заметите, что заголовок окна редактора FPDoc изменился, и показывает имя этого элемента вместе с именем файла документации. В редакторе FPDoc Вы можете перейти на подходящую вкладку чтобы редактировать соответствующий тег документации. И естественно, Вы можете использовать редактор FPDoc и для просмотра имеющейся документации, не начиная менять её.
2718
28-3\. Нажать кнопку Create Help (Создать элемент справки). Если Вы ещё не настроили пути для файлов FPDoc, IDE спросит, где хранить генерируемые файлы. Обычно у каждого проекта создают свою папку 'docs'.
19+3\. Нажать кнопку Create Help (Создать элемент справки). Если Вы ещё не настроили пути для файлов FPDoc, IDE спросит, где хранить генерируемые файлы. Обычно у каждого проекта создают свою папку 'docs'.
2920
30-4\. Вписать краткое описание
21+4\. Вписать краткое описание
3122
32-5\. Нажать кнопку Save слева или просто перейти к следующему элементу исходников (редактор автоматически сохраняет внесённые изменения по элементу, когда курсор с него уходит).
23+5\. Нажать кнопку Save слева или просто перейти к следующему элементу исходников (редактор автоматически сохраняет внесённые изменения по элементу, когда курсор с него уходит).
3324
3425## FPDoc для поставляемых исходников LCL и самого Lazarus
3526
36-Лежат в папке ($LazDir)\docs\xml, добавьте её в пути редактора FPDoc в Tools / Options / Environment / FPDoc Editor (Сервис / Параметры / Окружение / Редактор FPDoc)
27+Лежат в папке (\$LazDir)\docs\xml, добавьте её в пути редактора FPDoc в Tools / Options / Environment / FPDoc Editor (Сервис / Параметры / Окружение / Редактор FPDoc)
3728
3829## Редактирование FPDoc для поставляемых исходников FPC, RTL and FCL
3930
40-Файлы FPDoc для исходников FPC могут быть взяты из svn:
41-```
31+Файлы FPDoc для исходников FPC могут быть взяты из svn:
32+
33+``` bash
4234cd /home/username/yourchoice/
43- svn co http://svn.freepascal.org/svn/fpcdocs/trunk fpcdocs
35+svn co http://svn.freepascal.org/svn/fpcdocs/trunk fpcdocs
4436```
4537
46-Добавьте путь _/home/username/yourchoice/fpcdocs_ в Tools / Options / Environment / FPDoc Editor (Сервис / Параметры / Окружение / Редактор FPDoc)
38+Добавьте путь */home/username/yourchoice/fpcdocs* в Tools / Options / Environment / FPDoc Editor (Сервис / Параметры / Окружение / Редактор FPDoc)
4739
48-Для проверки результата можно посмотреть, например, на FPDoc для _TComponent.Name_.
40+Для проверки результата можно посмотреть, например, на FPDoc для *TComponent.Name*.
4941
5042## Планы на будущее
5143
52-Список todo сейчас содержит следующие пункты (расположены не в порядке приоритетности):
44+Список todo сейчас содержит следующие пункты (расположены не в порядке приоритетности):
5345
54- * Write a help editor for topics.
55- * Create nicer HTML output for the hint windows.
56- * Support Operators
46+- Write a help editor for topics.
47+- Create nicer HTML output for the hint windows.
48+- Support Operators
5749
5850### Уже сделано
5951
60- * Extend the link editor to show packages and identifiers
61- * Add documentation tags "example" to FPDoc Editor
62- * Add documentation tags "topic" to FPDoc Editor
63- * Make FPDoc Editor create new elements in documentation
64- * Make FPDoc Editor create new documentation files
65- * Adding a small toolbar makes it possible to use the available markup tags
66- * Make FPDoc Editor work on keydown in source code editor
67- * Add FPDoc Editor to IDE settings (showing and position in IDE)
68- * Make it work for fpc sources (rtl files already exist)
69- * Add settings to environment menu
70- * Make it work on project files also
71- * Propose to expand documentation tags with: "todo" and "notes" (no need for that, as there are alternatives)
72- * Reduce overhead even further
73- * All source elements are interpreted by FPDoc Editor using codetools
74- * Find inherited entries. For example TControl.Align of TButton.Align
75- * Optimization: inherited Entries are parsed on idle
76- * Optimization: xml files are cached, and only parsed once or if they changed on disk
77- * Add a HTML viewer. This is available by installing the turbopoweriprodsgn package
78- * Checks for invalid xml tags and auto repairs them
52+- Extend the link editor to show packages and identifiers
53+- Add documentation tags "example" to FPDoc Editor
54+- Add documentation tags "topic" to FPDoc Editor
55+- Make FPDoc Editor create new elements in documentation
56+- Make FPDoc Editor create new documentation files
57+- Adding a small toolbar makes it possible to use the available markup tags
58+- Make FPDoc Editor work on keydown in source code editor
59+- Add FPDoc Editor to IDE settings (showing and position in IDE)
60+- Make it work for fpc sources (rtl files already exist)
61+- Add settings to environment menu
62+- Make it work on project files also
63+- Propose to expand documentation tags with: "todo" and "notes" (no need for that, as there are alternatives)
64+- Reduce overhead even further
65+- All source elements are interpreted by FPDoc Editor using codetools
66+- Find inherited entries. For example TControl.Align of TButton.Align
67+- Optimization: inherited Entries are parsed on idle
68+- Optimization: xml files are cached, and only parsed once or if they changed on disk
69+- Add a HTML viewer. This is available by installing the turbopoweriprodsgn package
70+- Checks for invalid xml tags and auto repairs them
7971
8072---
81-*From the Free Pascal wiki, page "FPDoc Editor/ru", as the Internet Archive kept it on 2023-12-03. Copyright stays with the author who wrote it, according to the old wiki's [[Licensing]] page. If you have concerns about this material, [message the admin](/wiki-contact).*
73+*From the Free Pascal wiki, page "FPDoc Editor/ru", as it stood on 2020-08-22 after a change by Nashev, out of the wiki's dump of 2024-05-26. Copyright stays with the author who wrote it, according to the old wiki's [[Licensing]] page. If you have concerns about this material, [message the admin](/wiki-contact).*
74+Category: Russian (unfinished translation)

Back to history