Sign in Join

Live chat for Free Pascal, Lazarus, Delphi and every Pascal programmer.

Mailing lists / fpc-pascal / 2001-06

Units for POP3, SMTP, NNTP?

7 messages · 5 people ·

Reply by email Subscribe to this list Your subscription

Read-only archive. Use j and k to move between messages.

Michael Vogel

Hi!

I haven't found any units for the protocols POP3, SMTP or NNTP in the packages or on the server.

What is the best method?

Shall I:
- Take a unit designed for Delphi (is that possible?)
- Use a C-libary?
- Search again?
- Build my own one? ;-)

Are there any pages with 3rd-party FPC-Units?

Thanks!

Michael

"Macht's gut und danke für den Fisch" Sig geändert zum Gedenken an Douglas Adams (1952 - 11.05.2001) http://www.douglasadams.com/

Reply by email

Marco van de Voort
to Michael Vogel
Show quoted text 7 lines
I haven't found any units for the protocols POP3, SMTP or NNTP in the packages or on the server. What is the best method? Shall I: - Take a unit designed for Delphi (is that possible?)

Currently the ICS suite for Delphi more or less is compilable, but doesn't run very well due to problems with threading (making the RTL threadsafe is an ongoing effort)

- Use a C-libary? - Search again? - Build my own one? ;-)

All 4 are possible. A 5th one: check out www.openxp.de They are building a mail/fido/newsreader in FPC

Are there any pages with 3rd-party FPC-Units?

Only the contributed units pages on the FPC server. Some other website might point to a few FPC packages, but afaik the only large link base is the contributed units page.

Reply by email

Mirek Novak
to Michael Vogel: Hi! I haven't found any units for the protocols POP3, SMTP or NNTP in the packages or on…

Hi,
approx. 2 years ago I had to solve your problem (in BP under WIN95). We, at our company, had wide network of small food stores connected to central via modems (star topology) and proprietary DOS based software for transferring files when I came there (now I works elsewhere), there were only data transferred, no messages, so with my colleagues we buit linux based intranet at central and I wrote bridge between POP3/SMTP and this proprietary DOS SW. So I can send u, if u want my old sources - u can look at them, but they are "ugly" - most of rare comments in czech. As a best material for learning all important I can recommend RFC821 - SMTP and RFC1939 - POP3 for messaging protocols and RFC 2045 and 2046 - MIME for message completition. If u'll want a help with implementation I can offer it - but limited by my free time.

Mirek Novak

Michael Vogel píše:

Show quoted text 26 lines
Hi! I haven't found any units for the protocols POP3, SMTP or NNTP in the packages or on the server. What is the best method? Shall I: - Take a unit designed for Delphi (is that possible?) - Use a C-libary? - Search again? - Build my own one? ;-) Are there any pages with 3rd-party FPC-Units? Thanks! Michael -- "Macht's gut und danke für den Fisch" Sig geändert zum Gedenken an Douglas Adams (1952 - 11.05.2001) http://www.douglasadams.com/ _______________________________________________ fpc-pascal maillist - http://lists.freepascal.org/mailman/listinfo/fpc-pascal

Reply by email

Michael Vogel

Hi!

Mirek Novak wrote
So I can send u, if u want my old sources - u can look at them, but they are "ugly" - most of rare comments in czech.

Hmm, I can only read english, french, a little bit spanish and of course german, but czech? I regret no ;-)

As a best material for learning all important I can recommend RFC821 - SMTP and RFC1939 - POP3 for messaging protocols and RFC 2045 and 2046 - MIME for message completition. If u'll want a help with implementation I can offer it - but limited by my free time.

I will see. I'm not really sure, how to proceed. Maybe I write only a layer to another lib, that depends ...

Thanks!

Michael

"Macht's gut und danke für den Fisch" Sig geändert zum Gedenken an Douglas Adams (1952 - 11.05.2001) http://www.douglasadams.com/

Reply by email

Michael Vogel

Hi!

> - Build my own one? ;-) All 4 are possible.

If I would build my own unit: Are there any standards I should follow?

If the unit would be ready for production, I would contribute it (of course). In that case it maybe should behave like units known from delphi, the names should follow a standard, and so on ...

So if there's a rule I should follow, please let me know.

Tschau!

Michael

"Macht's gut und danke für den Fisch" Sig geändert zum Gedenken an Douglas Adams (1952 - 11.05.2001) http://www.douglasadams.com/

Reply by email

Thomas Schatzl
to Michael Vogel: Hi! If I would build my own unit: Are there any standards I should follow? If the unit…
Show quoted text 18 lines
Subject: Re: [fpc-pascal]Units for POP3, SMTP, NNTP? Hi! 07.06.2001 14:07:30, (Marco van de Voort) wrote: >> - Build my own one? ;-) > >All 4 are possible. If I would build my own unit: Are there any standards I should follow? If the unit would be ready for production, I would contribute it (of course). In that case it maybe should behave like units known from delphi, the names should follow a standard, and so on ... So if there's a rule I should follow, please let me know.

Well, I'd recommend using sockets - just because they're available on nearly any platform... well, and btw, I just started doing some (socket) network programming at the moment too =)
Please contact my by P-Mail if you're interested.... (I'd like to create some small tools / utilities and to learn new things too)

If someone's interested I could put the example programs I finished so far on my page.

Regards,
Thomas ()

Show quoted text 7 lines
Tschau! Michael -- "Macht's gut und danke für den Fisch" Sig geändert zum Gedenken an Douglas Adams (1952 - 11.05.2001) http://www.douglasadams.com/

42

Reply by email